Back to overview
Resolved

Borrow API — Morpho markets degraded

Jul 16, 2026 at 9:29am UTC
Affected services
Borrow API Health

Resolved
Jul 16, 2026 at 9:34am UTC

Resolved. The upstream Morpho API is available again and Borrow API requests for Morpho markets are returning normally. Follow-up: we are still rolling out a change to remove the Morpho API dependency on hot paths, expected live later today.

Created
Jul 16, 2026 at 9:29am UTC

We are experiencing degraded performance on the Borrow API affecting Morpho markets. An upstream Morpho API dependency is currently down, causing errors when fetching Morpho Blue borrow positions. Our team is working on a solution to bypass this dependency on hot paths. Started: 08:14 UTC (Jul 16).